Should I install Proxmox Virtual Environment 8 on a Legion Pro 5i Gen 8?

I'm looking for help and advice.  Click images to see larger version.

Morgonaut — Triple Boot HackintoshI have a little experience operating Proxmox VE on servers — which belong to clients.  But, they are running older versions.  Mostly, I just interact with the Linux guest VMs (Virtual Machines) hosted on Proxmox.

In the past, I have seen YouTube videos touting, "I run Linux, macOS, and Windows — on one machine, simultaneously — with Proxmox!"  Typically, however, the YouTuber is running Proxmox on a desktop PC — with a workstation CPU (Threadripper or Xeon W) — and at least 2 graphics cards.  At least one of the graphics cards is an AMD Radeon — for PCI-passthrough to the macOS guest VM.

My goal is to build a portable virtual environment.  To work with, I only have 2 graphics devices — Intel 13th-gen integrated-graphics and NVIDIA RTX 4060 discreet-graphics.  Except on standby, the system guzzles battery.  I don't expect to run this without the power supply (available).  Power concerns aside, I suspect I can run (at most) 2 VMs to 2 displays — including (or in addition to) the built-in display.  As I don't want to rely on another device to manage Proxmox, I am aware I will need to install a (light) desktop environment.

My major concern are the IOMMU groups for PCI-passthrough.  The RTX 4060 is definitely in a discreet group — to pass through to Windows or Linux.  But, macOS will only work with Intel or AMD graphics (or very old NVIDIA cards).  In the past, I have run Mojave on a guest VM in VirtualBox — on a Lenovo 2-in-1 (Intel 8th-gen Core i7 + NVIDIA MX230).  I did not find a way to pass through the Intel integrated-graphics.  Nor did I find a way to output sound.

I hope I have better luck with KVM and qemu.

Another concern is BIOS updates.  I haven't had to download a BIOS-update and run it from boot-media in over a decade.  Nor have I checked if that is still possible.  I see that I can download a BIOS update (.exe) from Lenovo Support.  But, can I run the update without Windows?  Although I plan to have a Windows VM, I don't plan to use the OEM (bare metal) Windows system.

Legion Pro 5i under light loadI have already backed up the initial state of the SSD.  So far, I have been using the Legion Pro 5i Gen 8 — solely with Linux Live-USB.  Here are the Geekbench 6 results (links launch new tab or window):

I don't know if this can be done.  A few years ago, I was excited to try.  But, much has changed.

Once more... I am looking for help and advice.  Thanks in advance!

  • Yesterday was not the day.  I did, however, decide to install the Live-USB I've been using.  I got tired of running compatibility-tasks after every reboot.

    Although I am comfortable with this temporary measure, it leaves much to be desired.  The only virtue I can find in it — I get to use (almost) everything from my 2019 Lenovo laptop on this 2023 Lenovo laptop (click images for larger version):

    2019 Lenovo    → 2023 Lenovo

  • I found an issue after resizing the Windows 11 (installation) partition.  Using gparted, I resized the partition — shrinking it from 474 GiB to 95 GiB (48 GiB used).  The Windows 11 installer boots.  Using Shift+F10 to launch command prompt, I have run chkdsk and shutdown (/s /t 0 /f).  I still haven't installed Windows 11.

    I have also run (sudo) ntfsfix (-d) on the partition.

    Clonezilla Live is unable to backup the partition.  I've already used Clonezilla Live to backup and restore the (factory-set) partitions; i.e. full-disk backup and restore.

    ntfsclone-ng.c: NTFS volume is scheduled for a check or it was shut down uncleanly. Please boot Windows or fix it by fsck.

    I have another NTFS volume, which Clonezilla Live has no problem backing up or restoring.  I created that partition, however, and never resized it.

    So... I have created a problem on the resized partition.  Can I solve it without restoring the (factory-set) backup (again)?

    On every other system I've dual-booted, the Windows (system) partition was already fully installed before I shrank the partition.  I don't recall any issues.  But, I resized the partition using Windows tools (e.g. Disk Manager), not Linux tools (e.g. gparted).

    I suspect I must resize the partition using diskpart from the Windows command prompt.  I have more things to try, before I try that.  But, this sums up how I feel:

  • Clonzilla camera-captSuccess!

    I booted to the Windows 11 installer, Shift+F10 for command prompt, and ran chkdsk C: /f /b (semi-redundant; /b → /r → /f).  After the challenge, "[Volume in use.  Would you like to run chkdsk on reboot?] Y/N", I typed "Y".  Then I executed shutdown /r /t 0 to reboot.  I booted to the Windows 11 installer, which included a much longer disk check than the other time.

    After shutdown, I started Clonezilla Live.  Click for larger image.

  • This is a good post, thanks for posting alot of us will learn something here.

  • Clonezilla Live chk-img-restorable resultHere is the confirmation, after running chk-img-restorable on the backup; i.e. all images are restorable, including the one for the Windows 11 partition (nvme0n1p3) →

    Click for larger image.

  • Cheers,  !

    I didn't expect this to turn into a blog.  But, it has.  Tomorrow I attempt to update the UEFI/BIOS via the bootable-USB method.

    Wish me luck!

  • Wishing you all the luck!

  • Lenovo EDU Community Access Denied server-errorI have tried many times to post a meaningful reply today.  If this works, I will try again.

    Click for larger image.

  • I have concerns about the stability of my laptop and/or its compatibility with Linux.

    ACPI error in dmesgUntil recently, running desktop Linux has not caused any major issues.  Earlier this week, I started noticing ACPI errors getting logged during shutdown.  After checking boot logs and dmesg, I noticed the following errors reported; click for larger image — highlighted line from dmesg shows the errors follow waking from sleep.

    I did not see this a week ago.  And none of the recent updates for my desktop Linux system would explain the sudden rash of power-management errors.

    I am concerned, because MX Linux is a Debian-based distro — like Proxmox VE 8 — which is based on Debian 12 "Bookworm".

    The fun never stops. smh

    btw- This is almost the same reply I couldn't post all morning, as mentioned in this reply.  The problem appears to have been caused by including a path to a Linux system file; i.e. the "boot logs" I mentioned.

  • I tried almost all the things an IT professional would try.  I deleted cookies.  I closed and opened the browser.  And so on.

    Cause of Access DeniedI overlooked something, however, in the body of my reply.  I included a path common to all Linux systems.  A path commonly included in Linux discussion forums.  In the image to the right, it is the path which ends with "boot.log". (click to enlarge)

    Instead of the form-validation flagging the problematic text, the server blocked access to my user-agent/IP-address combo.  Google Chrome and Brave are both Chromium-based browsers, running on Linux, and using my IP address.  Firefox, however, is not that combo — same IP address, different user-agent.

    See the successful (path-omitted) version of my comment in this reply I posted.

    It's always something. smh